首页 > 题解 > poj 1019 Number Sequence

poj 1019 Number Sequence

不知为何是DP

传送门

Description

A single positive integer i is given. Write a program to find the digit located in the position i in the sequence of number groups S1S2…Sk. Each group Sk consists of a sequence of positive integer numbers ranging from 1 to k, written one after another.
For example, the first 80 digits of the sequence are as follows:
11212312341234512345612345671234567812345678912345678910123456789101112345678910
Input

The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by one line for each test case. The line for a test case contains the single integer i (1 ≤ i ≤ 2147483647)
Output

There should be one output line per test case containing the digit located in the position i.
Sample Input

2
8
3
Sample Output

2
2

题意:数学类问题,题意是给一串 1 12 123 1234 12345 123456 。。。。这样的数字问第i个数字是多少。

这题的技巧在于第i个数与第i-1个数的位数差不定,可以利用公式:(int)log10(double(i))+1,当增加的数字是10的幂次关系时个数会变化。

预处理一下表就行了

#include <cstdio>
#include <cmath>
#define N 40000
using namespace std;
unsigned int a[N],sum[N];
void init()
{
    a[1]=1;
    sum[1]=1;
    for (int i=2;i<31270;i++)
        a[i]=a[i-1]+(int)log10((double)i)+1,sum[i]=sum[i-1]+a[i];
}
main()
{
    int T,n;
    init();
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        int i=1;
        while(sum[i]<n) i++;
        int pos=n-sum[i-1],ans=0;
        for (i=1;ans<pos;i++)
            ans+=(int)log10((double)i)+1;
        printf("%dn",(i-1)/(int)pow(10.0,ans-pos)%10);
    }
}