首页 > 题解 > bzoj 2882 工艺

bzoj 2882 工艺

Description

小敏和小燕是一对好朋友。
他们正在玩一种神奇的游戏,叫Minecraft。
他们现在要做一个由方块构成的长条工艺品。但是方块现在是乱的,而且由于机器的要求,他们只能做到把这个工艺品最左边的方块放到最右边。
他们想,在仅这一个操作下,最漂亮的工艺品能多漂亮。
两个工艺品美观的比较方法是,从头开始比较,如果第i个位置上方块不一样那么谁的瑕疵度小,那么谁就更漂亮,如果一样那么继续比较第i+1个方块。如果全都一样,那么这两个工艺品就一样漂亮。

Input

第一行两个整数n,代表方块的数目。
第二行n个整数,每个整数按从左到右的顺序输出方块瑕疵度的值。

Output

一行n个整数,代表最美观工艺品从左到右瑕疵度的值。

Sample Input

10

10 9 8 7 6 5 4 3 2 1

Sample Output

1 10 9 8 7 6 5 4 3 2

HINT

【数据规模与约定】

对于20%的数据,n<=1000

对于40%的数据,n<=10000

对于100%的数据,n<=300000

题解

因为只是会有环的情况,那就把这个串接到自己的后面,建出SAM。

然后每次找最小的跑就行了。。因为字符集会很大,所以儿子用map存

还有注意PE。。。

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <map>
#define it map<int,int>::iterator
#define N 600010
using namespace std;
int dis[N<<1],fa[N<<1],a[N],sz=1,root=1,last=root,len,t,k,n;
map <int,int> ch[N<<1];
void insert(int x)
{
    int now=++sz,pre=last;last=now;
    dis[now]=dis[pre]+1;
    for (;pre && !ch[pre][x];pre=fa[pre]) ch[pre][x]=now;
    if (!pre) fa[now]=root;
    else
    {
        int q=ch[pre][x];
        if (dis[q]==dis[pre]+1)
            fa[now]=q;
        else
        {
            int nows=++sz;dis[nows]=dis[pre]+1;
            ch[nows]=ch[q],fa[nows]=fa[q],fa[q]=fa[now]=nows;
            for (;pre && ch[pre][x]==q;pre=fa[pre]) ch[pre][x]=nows;
        }
    }
}
void work()
{
    for (int i=1,now=root;i<=n;i++)
    {
        it t=ch[now].begin();
        printf(i==n?"%d\n":"%d ",t->first);
        now=t->second;
    }
}
main()
{
    scanf("%d",&n);
    for (int i=1;i<=n;i++) scanf("%d",&a[i]);
    for (int i=1;i<=n;i++) insert(a[i]);
    for (int i=1;i<=n;i++) insert(a[i]);
    work();
}